Блокировка https сайтов на роутерах Mikrotik | Ubiquiti форум UBNT: инструкции, настройка

Блокировка https сайтов на роутерах Mikrotik

dimacbz

Moderator
16 Июн 2014
1.437
228
75
Появилась блокировка сайтов https на роутерах фирмы Mikrotik с версии RouterOS 6.41 и выше.
После добавления правила обязательно перезагрузите роутер.
Код:
/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*.youtube.com action=reject
Свой сервер авторизации WIFI по СМС
 
Последнее редактирование:

Alekssander

новичок
30 Авг 2019
1
0
3
30
Появилась блокировка сайтов https на роутерах фирмы Mikrotik с версии RouterOS 6.41 и выше.
После добавления правила обязательно перезагрузите роутер.
Код:
/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*.youtube.com action=reject
НЕ работает.
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.437
228
75
Появилась блокировка сайтов https на роутерах фирмы Mikrotik с версии RouterOS 6.41 и выше.
После добавления правила обязательно перезагрузите роутер.
Код:
/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*.youtube.com action=reject
НЕ работает.
Работает для большинства сайтов в процентном соотношении 99,9%, проверено только что на hAP-AC2 с прошивкой 6.45.5 и популярных браузерах (обновленных)..
Переместите это правило выше остальных, перезагрузите роутер. Откройте другой браузер и проверьте. Если есть куки, то блокировать НЕ будет, объясню ниже.

Google, YouTube и т.д. ... они используют QUIC (протокол на основе UDP) вместо обычного HTTP/2 (протокол на основе TCP).
Они, конечно, все еще поддерживают старые протоколы, но это просто запасной вариант. Если браузер поддерживает QUIC, он будет использовать QUIC.

TLS-хост не работает с QUIC, так как зависит от TCP-соединения.

Что же касается конкретно Youtube.com:
При сохранённых КУКАХ youtube (html5) он переходит к CDN и отдают контент с других хостов, которые не имеют никакого отношения к TLS-хосту youtube, соответственно блок не срабатывает. Не будет Куков, блок сработает. Работает для 99,9% сайтов.
 
Последнее редактирование:

murathan

новичок
12 Ноя 2019
3
0
3
41
Появилась блокировка сайтов https на роутерах фирмы Mikrotik с версии RouterOS 6.41 и выше.
После добавления правила обязательно перезагрузите роутер.
Код:
/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*.youtube.com action=reject
Свой сервер авторизации WIFI по СМС
аппаратная нагрузка есть?
я вот через layer 7 блочил , так потом все висло , а нафиг отрубил этот вариант