Проблема с авторизацией на телефонах через Гостевой доступ!! | Ubiquiti форум UBNT: инструкции, настройка

Проблема с авторизацией на телефонах через Гостевой доступ!!

Prorace

новичок
27 Авг 2014
6
1
3
Добрый день! Имеются 11 точек Unifi Pro, версия контроллера 4.8.14. Включил режим авторизации через Ваучеры, на некоторых устройствах а именно телефонах Samsung, HTC после подключения к WiFi, в браузере переадресует на страничку ввода Ваучера а на некоторых нет, IPhone и китайские Noname, причем перепробовал все браузеры. Как быть в данной ситуации? Есть ли возможность как то вручную в браузере ввести адрес страницы авторизации? Т.к. после редиректа на страницу ввода Ваучера в URL сразу подставляется Mac устройства, Mac точки и сид. Заранее спасибо!
 

Olekos

участник
22 Сен 2015
192
11
20
Производитель не парится адаптированным порталом.
Конечно можно все сделать свое и как надо!
Settings -> Guest Control -> EXTERNAL PORTAL SERVER
Но нужно много что сделать!
Поднять веб сервер, перенести файлы с портала контроллера и переписать.
GET запрос в сессию и переадресация на свою страницу. Там уже свой дизайн + скрипт авторизации на контроллер.
 
Автор
P

Prorace

новичок
27 Авг 2014
6
1
3
В общем методом можно сказать тыка =) пришел к выводу что такая история с авторизацией только на точках UniFi AP PRO, на UniFi AP и UniFi AP Outdoor+ все отлично, самое что интересно UniFi AP гораздо стабильней работает чем PRO, а стоит гораздо меньше. Вот что теперь с этими PRO делать... =(
 
Автор
P

Prorace

новичок
27 Авг 2014
6
1
3
Так же думал что только на 5 ГГЦ, отключил 5, оставив только 2.4 ГГЦ та же фигня. И вот сегодня допытал точки, и суть такова: приобретались они паками (по 3 шт в паке) 2 пака сразу и один спустя год. Так вот те которые раньше приобретались 6 штук (2 пака mac адресс у них начинается с 24-A4-3C...) выводит страницу ввода ваучера на компьютерах (ноутбук, планшет Windows) и телефонах HTC и Samsung (которые смог найти на время теста), а на Iphone и других нет, а на последних 3 точках (приобретались через год, mac адресс у них начинается с 04-18-D6... ) ситуация с точностью наоборот у кого выводилось окно, перестало выводиться (причем и на ноутах и ПК тож), а у IPhone и Fly, ZTE и т.д. открывается. Прошивка обновилась и у всех одинаковая! Как такое может быть?
 
Последнее редактирование:

Olekos

участник
22 Сен 2015
192
11
20
вопрос на всякий случай:
вы подключаете дивайс и заходите на страницу браузера вводите нужную страницу и далее либо попадаете на страница авторизации либо нет. Если нет то браузер крутит до тайм-аута.
про https в курсе?
 
Автор
P

Prorace

новичок
27 Авг 2014
6
1
3
Про https вкурсе =) Да, подключаюсь устройством допустим телефоном, на некоторых сразу выскакивает сообщение что необходимо войти в сеть и происходит переход в браузер где открывается страничка ввода ваучера а на некоторых просто в браузере открываешь страничку типа http://ya.ru и происходит переадресация на ввод пароля ваучера. Если этого не происходит, правильно вы говорите браузер крутит тот же ya.ru до таймаута. Вот самое что странное что на Unifi AP и Outdoor+ все исправно работает
 

Olekos

участник
22 Сен 2015
192
11
20
Странно! начинаем перебирать все с 0
если переадресация не происходит может точка вообще не видит устройства!
все на одном контроллере?
в контроллере проблемным девайсы появляются?
IP правильные выдает проблемным девайсам?
порты открыты?

Теперь глубже :)
посмотрите и сравните system.cfg
особенно строки # ebtables и REDIRECT_HTTP и # redirector
 
Автор
P

Prorace

новичок
27 Авг 2014
6
1
3
Да, все точки на одном контроллере, все без ошибок, общее количество 13 штук из них 9 Unifi AP PRO, одна старенькая Unifi AP и 3 Outdoor +. Контроллер девайсы видит, висят в госте как не авторизованные, вручную через контроллер авторизовываются и интернет появляется. IP присваиваются правильные (ip адрес, маска, шлюз и dns все как надо). На счет system.cfg как приеду завтра на работу сразу гляну! =) Еще был такой момент, когда менял PRO на Uotdoor+ все начинало работать и как обратно PRO воткнул (отключил 5ГГц и изменил канал) она заработала это было вчера вечером, а сегодня утром опять перестала пускать, и побегав с точками пришел к выводу который чуть раньше здесь написал! Вот непонятно почему одни девайсы пускает, а другие нет и наоборот o_O
 
Автор
P

Prorace

новичок
27 Авг 2014
6
1
3
Разобрался в чем проблема!!!! DHCP сервер имеет адрес 192.168.50.254 и раздает IP адреса двух подсетей 50 и 60, так вот точки Unifi которые получили 50 подсеть пускает устройства так же с 50 подсетью а с 60ой нет и наоборот точки с 60 подсетью пускают только 60-ых! Теперь надо заставить чтоб в двух подсетях работала!
 

Olekos

участник
22 Сен 2015
192
11
20
Поправите если я не правильно понял:

у вас DHCP раздает два пула 192.168.50.х и 192.168.60.х
точки как и девайсы получают IP динамически
если точка получила IP в подсети 50 то смартфоны в этой же подгруппе подключаются,
а если смартфоны в 60 - то нет! ну и наоборот
но разные смартфоны ведут себя по разному - одним это не помеха а другие не подключаются