Mikrotik Hairpin NAT. Локальный трафик через внешний IP + проброс порта | Ubiquiti форум UBNT: инструкции, настройка

Mikrotik Hairpin NAT. Локальный трафик через внешний IP + проброс порта

Публиковать ещё подобные темы?

  • Да

    Голосов: 2 100,0%
  • Нет

    Голосов: 0 0,0%
  • Мне без разницы

    Голосов: 0 0,0%

  • Всего проголосовало
    2

dimacbz

WiFi-SMS.com
16 Июн 2014
1.373
212
75
wifi-sms.com
Здравствуйте.
Представим ситуацию:
У вас в помещении стоит роутер Микротик со статическим белым (выделенным) IP и реализовано в данном помещении например Видеонаблюдение или что-либо ещё.

В примере настройки такие: порт 9786 от сервера Видеонаблюдения с локальным IP 192.168.0.114. И вы имеете статический белый (выделенный) IP 78.107.58.100(например).
Соответственно у вас IP и порт - другие.

Все манипуляции выполняются в разделе: IP -> Firewall -> NAT
Сначала сделаем проброс порта. Где "ether1" - это интерфейс с кабелем в "интернет".

forward_port_mikrotik1.jpg
forward_port_mikrotik2.jpg


Те же настройки проброса порта, только через Терминал:
Код:
/ip firewall nat
add action=netmap chain=dstnat dst-port=9786 in-interface=ether1 protocol=tcp to-addresses=\
    192.168.0.114 to-ports=9786
Вы к примеру, чтоб смотреть на своём смартфоне удаленно, - вбили настройки и ваш статический белый (выделенный) IP. С сотовой сети или с другого места с интернетом всё показывает хорошо.
Но, как только вы находитесь в том же помещении и подключены к этой же локальной сети (WIFI) - ничего не работает.
В этом нам поможет настройка Hairpin NAT для микротика.

Приступаем к настройке. Выполняйте такие же настройки, заменяя на свои IP и порты.

1-ое правило:
hairpin_nat_mikrotik1.jpg
hairpin_nat_mikrotik2.jpg


2-ое правило:
hairpin_nat_mikrotik3.jpg
hairpin_nat_mikrotik4.jpg


Те же настройки, только через Терминал:
Код:
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=78.107.58.100 dst-port=9786 protocol=tcp \
    src-address=192.168.0.0/24 to-addresses=192.168.0.114

add action=masquerade chain=srcnat dst-address=192.168.0.114 dst-port=9786 protocol=\
    tcp src-address=192.168.0.0/24
Свой сервер авторизации WIFI по СМС
 
Последнее редактирование: