Change background image

Airvision - потеря видеопотока.

Тема в разделе 'Видеонаблюдение', создана пользователем Sakhalin, 22 фев 2014.

  1. Sakhalin

    Sakhalin новичок

    Регистрация:
    19 июн 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    0
    Здравствуйте.
    Подскажите где подкрутить. Имеем 18камер + Airvision Ubuntu + 6 мониторов наблюдения в разных комнатах. Переодически все мониторы теряют видеопоток. Выражается это в погасании окошек с видеоизображением или зависание изображения в окошках. Причем могут терять его несколько раз в течении часа самостоятельно или при конекшене новой сессии монитора, а могут не терять весь день. Так-же замечено, что подобное происходит если в мониторе пробегает волна "Connected-Disconected" по всем камерам в вкладке "devices". Причем от чего эта волна иногда пробегает я тоже понять немогу. Железо можно исключать, сбои питания тоже. Количество "потерь потока" нарастает вместе с увеличением количества камер. Раньше стояло 6 камер и подобное случалось редко, потом чем больше их становилось, тем чаще стало это происходить. У всех камер статические адреса, всем прописан внутренний сервер DNS всё оборудование включая БП камер висит в 19" стойке на упске.

    Почему при битрейте 4096 и 2048 лезут артефакты, вроде сжатие меньше, сетка позволяет больщее. Сейчас поставил работает 1024 и пробую катать 512, на этих битрейтах артефактов нет. Загрузка проца не сервере выше 20% небывает, память 6Гб свободно, загрузка ethernet по показометрам свича 5-10% от 1000Mbit/s FD. Вот думаю может ему воткнуть вторую сетевуху и камеры вынести чисто на неё, а разбор видео по локалке со второй сетевухи делать? Но теоретически пропускной способности сетевухи должно хватать за глаза и на 50камер.
     
    Последнее редактирование: 22 фев 2014
  2. Sakhalin

    Sakhalin новичок

    Регистрация:
    19 июн 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    0
    Добил я эту замороку.
    Вся проблема в google chrome.

    После обновления (ручного или автоматического) до 21-й версии Chrome по умолчанию включает PPAPI-флэш, который пока явно не доработан и вызывает множество нежелательных побочных эффектов:

    • отключение аппаратного ускорения (низкий FPS, ухудшение качества графики)
    • падения флэш-плагина

    решение изменяем ярлык запуска: ................chrome.exe --disable-bundled-ppapi-flash

    Тестирую, вроде пашет приятно, упала загрузка проца на мониторных компах.
     
  3. ubnt.su

    ubnt.su Administrator

    Регистрация:
    1 июн 2012
    Сообщения:
    1.635
    Симпатии:
    52
    Баллы:
    60
    Спасибо, Сахалин.

    Абсолютно неожиданный глюк. В копилочку.
     
  4. Sakhalin

    Sakhalin новичок

    Регистрация:
    19 июн 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    0
    Все равно рвется. :( Сижу ковыряю ubuntu.
    Беда прям какая-то. Пашет пашет бряк оторвалось...
     
  5. ubnt.su

    ubnt.su Administrator

    Регистрация:
    1 июн 2012
    Сообщения:
    1.635
    Симпатии:
    52
    Баллы:
    60
    Ваша "волна" называется Ethernet-шторм.
    Сеть забивается пока пакеты по ttl не умрут.

    Важно понять что его вызывает. WireShark вам в компьютер!
     
  6. Sakhalin

    Sakhalin новичок

    Регистрация:
    19 июн 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    0
    Хм. По логам загрузка коммутаторов не бывает больше 5-10%. Петель нет. Был косячок с ntpd, исправил. Поглядим...
     
  7. Sakhalin

    Sakhalin новичок

    Регистрация:
    19 июн 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    0
    Еще вопрос по evostream. Файл pushPullSetup.xml как я понял создается автоматом при загрузке. А вот что используется в качестве шаблона для создания?

    так же возник вопрос о строке в логах "failed to resolve EvoCameraEntry"
     
  8. Po1soN

    Po1soN новичок

    Регистрация:
    11 фев 2015
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    0
    У кого нибудь есть решение этого вопроса ? борюсь уже 5 день, глюк непонятен
     

Поделиться этой страницей