Не прошивается NanoBeam m5 300 :( | Ubiquiti форум UBNT: инструкции, настройка

Не прошивается NanoBeam m5 300 :(

KennySyS

участник
9 Ноя 2016
34
0
8
35
Всем привет. Проблема такая:
После прошивки на версию v5.5.6 (XW) nanobeam после ребута начал сбрасываться на начальные настройки, не прошивается (процесс прошивки идет нормально, но по окончанию возвращается на 5.5.6). Пробовал шить по web и ssh на 5.5.10, 6.0.6 - безрезультатно.:(:(:(
 

start

эксперт
21 Сен 2014
763
124
45
Нельзя было так делать, скорее всего получился кирпич.
У нанобимов разные ревизии железа были. Разметка флешки повредилась.
Мое мнение надо подключаться по UART к точке и пробовать шить.
 
Автор
KennySyS

KennySyS

участник
9 Ноя 2016
34
0
8
35
Нельзя было так делать, скорее всего получился кирпич.
У нанобимов разные ревизии железа были. Разметка флешки повредилась.
Мое мнение надо подключаться по UART к точке и пробовать шить.
Спасибо за ответ, этого я и боялся :eek:
 

ubnt.su

Administrator
1 Июн 2012
1.635
52
60
"Сбрасывается на начальные настройки" и "кирпич" - диаметрально противоположные реакции.
Будем надеяться, что на другом железе разбивка флеш-памяти просто другая, поэтому копирование проходит в dev>null. Пробуйте шить правильной прошивкой.
 
Автор
KennySyS

KennySyS

участник
9 Ноя 2016
34
0
8
35
"Сбрасывается на начальные настройки" и "кирпич" - диаметрально противоположные реакции.
Будем надеяться, что на другом железе разбивка флеш-памяти просто другая, поэтому копирование проходит в dev>null. Пробуйте шить правильной прошивкой.
что значит правильной прошивкой? я шил xw 6.0.6 с офф сайта.
 

start

эксперт
21 Сен 2014
763
124
45
Затерлась часть флешки, в которой должен содержаться конфиг.
По ssh дайте команду cat /proc/mtd затем dmesg результаты сюда
Вот оригинальная разбивка
Код:
[    0.069000] Creating 6 MTD partitions on "ath-nor0":
[    0.069000] 0x000000000000-0x000000040000 : "u-boot"
[    0.070000] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.072000] 0x000000050000-0x000000150000 : "kernel"
[    0.073000] 0x000000150000-0x0000007b0000 : "rootfs"
[    0.074000] mtd: partition "rootfs" set to be root filesystem
[    0.074000] 0x0000007b0000-0x0000007f0000 : "cfg"
[    0.075000] 0x0000007f0000-0x000000800000 : "EEPROM"
 
Последнее редактирование:
Автор
KennySyS

KennySyS

участник
9 Ноя 2016
34
0
8
35
Затерлась часть флешки, в которой должен содержаться конфиг.
По ssh дайте команду cat /proc/mtd затем dmesg результаты сюда
Вот оригинальная разбивка
Код:
[    0.069000] Creating 6 MTD partitions on "ath-nor0":
[    0.069000] 0x000000000000-0x000000040000 : "u-boot"
[    0.070000] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.072000] 0x000000050000-0x000000150000 : "kernel"
[    0.073000] 0x000000150000-0x0000007b0000 : "rootfs"
[    0.074000] mtd: partition "rootfs" set to be root filesystem
[    0.074000] 0x0000007b0000-0x0000007f0000 : "cfg"
[    0.075000] 0x0000007f0000-0x000000800000 : "EEPROM"
txt по ссылке: http://rgho.st/private/6VhtyS4yC/d121311a01ec3473c61e3f21ddd4c012
 

start

эксперт
21 Сен 2014
763
124
45
Надо попробовать по tftp прошиться.
Если не поможет, то UARTом подключаться и в консоли следующие команды.
1. urescue -f перезапишет загрузчик и переведет точку в режим прошивки
2. прошить по tftp
3. mtdparts default
4. save