Wifi sms авторизация (идентификация) Spot4 в сетях wifi. Wifi Авторизация по звонку. | Ubiquiti форум UBNT: инструкции, настройка

Wifi sms авторизация (идентификация) Spot4 в сетях wifi. Wifi Авторизация по звонку.

4,80 звёзд 12 Votes

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Идентификация и авторизация пользователей в сетях Wi-Fi Spot 4. WiFi авторизация пользователей по смс и по звонку* на Вашем сервере БЕЗ абонентской платы!

Предлагаем ПО "Spot4" для авторизации в сети wifi по смс (идентификации) и по звонку*.
Данная система авторизации (идентификации) WIFI пользователей по SMS или по звонку, ставится на Ваш сервер (компьютер, VPS), а не Вы подключаетесь к кому-либо. Без "облаков". Вы приобретаете продукт навсегда, без каких-либо дополнительных платежей. Тех. поддержка, обновления бесплатны.
-----

Возможности ПО Spot4:
  • Возможность подключать НЕОГРАНИЧЕННОЕ количество хотспотов/точек/роутеров/площадок.
  • Возможность проводить идентификацию абонента путём отправки/приёма СМС, логина/пароля.
  • Возможность проводить идентификацию абонента путём совершения звонка от абонента на сервер (на вашу бесплатную виртуальную атс Asterisk)*.
  • Возможность проводить идентификацию абонента путём совершения звонка от абонента на сервер (с помощью бесплатного сервиса sms.ru)*.
  • Привязка MAC-адреса мобильного устройства к номеру телефона абонента.
  • Возможность накладывать ограничения на количество конечных устройств гостя, подключённых к вашей гостевой сети WiFi, длительность сессии.
  • Возможность отправки/получения СМС через большое число агрегаторов с помощью api http или USB модем.
  • Личные кабинеты (отдельный на каждый хотспот) владельца площадки.
  • Возможность перенаправлять абонента на вашу рекламную страницу после авторизации.
  • Возможность изменять страницу приветствия (на каждый хотспот отдельно) путем редактирования html, css.
  • Статистика по количеству переданного и отправленного абонентами трафика.
  • Возможность выгрузить (в формате csv) номера телефонов и истории посещения (NETFLOW).
  • Информация о зарегистрированных в системе абонентах и их сессиях, телефонные номера абонентов.
  • IP-адреса посещенных ресурсов в Интернет (NETFLOW).
-----
Предоставляем Тестовое ПО Spot 4 для установки на Свой сервер.
По всем интересующим вопросам обращайтесь по контактам ниже.

---
ВНИМАНИЕ!
Тестовое ПО БЕЗ Лиц. ключа работает Только в LAN сети Mikrotik! Например Mikrotik имеет адрес 192.168.88.1. Сервер должен быть в этой же LAN сети, например с адресом 192.168.88.50
В тестовом ПО имеется дополнительно ряд ограничений (lock на отправку смс, kick юзера через меняющийся интервал времени и так далее). Для снятия всех ограничений - требуется приобрести Лиц. ключ.
---------------------------------------
Возможно подключение Вашего микротика к нашему серверу для тестирования Spot. Для этого пишите по контактам ниже.
Файлы для самостоятельной установки (если вам нужна удаленная установка и настройка - обращайтесь по контактам ниже):
---
Краткая инструкция по установке spot4 на Debian 10 (spot4-278) и подготовке микротика:
Обновлено: 27.03.2020

Краткая инструкция по подсоединению удаленных Хотспотов (микротика в кафе например), логи, добавление администратора, вход по паролю, редактирование темы:

Тестовое ПО spot4 v278 (glibc >=2.19), имеются ограничения. Для снятия всех ограничений - требуется приобрести Лиц. ключ:
Обновлено: 27.03.2020
-----
По многим просьбам сделали ВИРТУАЛЬНЫЙ образ машины Debian 10 с установленным тестовым ПО Spot 4.6.
Готовый Виртуальный сервер Debian 10 с установленным ПО spot4, создавался в VirtualBox Oracle
https://www.oracle.com/virtualization/technologies/vm/downloads/virtualbox-downloads.html

Формат .ova, вес 1.88 ГБ (выбираете в программе "файл - импорт конфигураций").
Логин/пароль: test/test
su -
root: test
Зарегистрируйтесь на SMS.RU для отправки СМС и впишите свой api_id в файл (/opt/spot4/config/config.json).
Далее настраивайте свой микротик по инструкции.
Обязательно читайте инструкцию по установке, там описано как настроить работу с микротиком!
Что-то не получается? Пишите по контактам ниже, поможем!
Обновлено: 24.06.2020

------

Что нужно для запуска Spot4:

а) Компьютер с Linux x64 (Debian, Ubuntu, Centos) - можно виртуальную машину (VPS).
Дешево арендовать VPS сервер можно например тут: JUSTHOST.RU
Рекомендуем Debian 10 https://www.debian.org/
Рекомендуемые системные требования к серверу (компьютеру):
2vCPU (2 ядра), 2 Gb RAM, 20Gb SSD
Требования зависят от нагрузки и количества обрабатываемых данных.

б) Mikrotik роутер (любой).
в) USB модем (ZTE MF667, ZTE MF823D) ИЛИ HTTP API любого смс агрегатора, например этот: SMS.RU
---------------------------------------

Вопросы - Ответы:
Вы работаете с Юридическими лицами?

- Да. Наши клиенты: как государственные заказчики, физические и юридические лица, так и зарубежные заказчики.
-----
С каким WIFI оборудованием работает Spot4?
- С любым. В роли хотспота должны выступать: Роутеры доступа Mikrotik (Любой, Рекомендуется), Keenetic (KeeneticOS, не NDMS), роутеры со сторонними прошивками, поддерживающие Coova-Chilli или совместимое ПО.
-----
Дополнение к ПО Spot4: авторизация по звонку*.
  • Абсолютно бесплатный способ авторизации как для вас, так и для пользователя.
  • Пользователю достаточно позвонить по номеру, который вы укажете.
  • Звонок сразу сбрасывается при поступлении / определении номера (пользователь слышит гудки), поэтому бесплатен для звонящего даже из роуминга.
Авторизация существует в 2-ух вариантах: через собственную бесплатную АТС Asterisk (можно поставить на тот же сервер) с собственным телефонным номером ИЛИ через бесплатную АТС от SMS.RU (в этом случае вам не нужно иметь свою АТС и свой номер телефона).

Что нужно для авторизации по звонку?

1) Своя АТС Asterisk со своим номером телефона:
Получите и установите дополнение.
а) бесплатная виртуальная атс Asterisk (можно установить на тот же сервер, где установлен Spot4).
б) телефонный номер (городской или 8800 или любой другой) - собственный (например с модемом huawei и сим картой) или арендованный у любого провайдера, например здесь: Zadarma.com

ИЛИ

2) Зарегистрируйтесь на SMS.RU:
Получите инструкцию и установите дополнение.
Далее включаете авторизацию по звонку.
Для данного метода не нужно иметь свою атс и свой номер. Авторизация проходит через номер SMS.RU московский, вида +7495120****. Абсолютно бесплатен.

Авторизация по звонку через SMS.RU не может работать одновременно с авторизацией по звонку через свою собственную атс. Выбирайте что-то одно.

77467747
-----
По любым вопросам обращайтесь по контактам ниже.
-----
Контакты:

Viber, Whatsapp, Telegram: +79626222731
e-mail: info@wifi-sms.com

------
Тестовый личный кабинет:

Логин: test
Пароль: test
------

Тестовая авторизация Spot4:

а) Авторизация стандартная.
б) Авторизация не стандартная. Чтобы авторизоваться, гость должен отправить смс на номер сервера (получение смс от гостя с помощью USB модема ZTE MF823).
-----
*
- дополнение к ПО Spot4 "авторизация по звонку" приобретается отдельно.

Создано: 30.08.2017 г.
Отредактировано: 12.09.2020 г.


-----
Tags: авторизация по звонку, wifi авторизация по звонку, идентификация по звонку, spot4, spot 4, spot 4.7, spot4 sms, spot4 debian, spot 4.6 sms, wifi sms авторизация, wifi смс идентификация, wi-fi авторизация, wi-fi аутентификация,wi-fi идентификация, wifi sms, wifi смс, sms авторизация, смс авторизация, система авторизации, сервис авторизации, hotspot, хотспот, авторизация, идентификация, аутентификация, организация хотспота, рестораны, кафе, гостиницы, гостевой WiFi, Wi Fi идентификация, Wi Fi авторизация, идентификация вай фай, вай фай авторизация, системы авторизации wi fi, доступ к Wi Fi, гостевая сеть, guest wi fi, wi fi hotspot, wi fi hot spot, Wi Fi sms, вай фай смс, смс идентификация, хотспот, хот спот, публичный wi fi, публичный вай фай

44184419442044214422442344244425442677467747
 
Последнее редактирование:

ntman

участник
24 Авг 2017
53
6
10
47
извините, а кто хранит данные и как это сертифицированно ? (я знаю точку зрения что телефон не является персональными данными, но "список шаблонных отписок" прилагается?)
и зачем микротик целый ? городил такое на openwrt+телефон на андроиде с прогой, добивая кучу "вкусняшек"
 
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
извините, а кто хранит данные и как это сертифицированно ? (я знаю точку зрения что телефон не является персональными данными, но "список шаблонных отписок" прилагается?)
и зачем микротик целый ? городил такое на openwrt+телефон на андроиде с прогой, добивая кучу "вкусняшек"
Микротик нужен для обработки ряда задач. Данные хранятся у Вас на Вашем сервере, netflow собирается. Лицензия в этом случае не нужна. Можете написать в Роскомнадзор, - они Вам ответят. Номер телефона - это обезличенные данные.
С 01.01.2016 г. владельцев открытых сетей Wi-Fi будут штрафовать за отсутствие обязательной идентификации пользователей. Запрет на анонимный Wi-Fi изложен в Постановлении Правительства РФ № 758 о доступе к публичному Интернету: «ответственность распространяется на всех, кто оказывает универсальные услуги связи по передаче данных и предоставлению доступа к сети Интернет с использованием пунктов коллективного доступа».
Идентифицировать пользователей предлагается с помощью:
  1. документа, удостоверяющего личность (если речь идет о пунктах коллективного доступа);
  2. учетной записи на сайте госуслуг;
  3. номера мобильного телефона:
При попытке подключиться к сети Wi-Fi предложат ввести номер телефона. На указанный номер придет SMS с кодом подтверждения. После его ввода пользователь получит доступ в Интернет. Стоимость различная у разных sms-провайдеров - 0,3 – 1,0 руб. за sms. Оплата осуществляется конкретным пользователем или владельцем сети.
Владельцев сети, которые не реализуют ни один из этих способов до начала 2016 г., ждет неприятный сюрприз: за предоставление анонимного доступа к Wi-Fi индивидуальным предпринимателям грозит штраф от 5 до 50 тыс. рублей, юридическим лицам – от 100 до 200 тыс. рублей. Повторное нарушение обойдется ИП в 100 тыс. рублей или дисквалификацией на срок до трех лет, а юрлица заплатят до 300 тыс. рублей.
 
Последнее редактирование:

BigManTash

новичок
21 Июл 2017
1
0
3
46
Контроллер Unifi, на Windows 7 (х86). Работает как ХотСпот, интеграция с 1С Отелем (паспортные данные) по ваучерам. Нужно сделать еще дополнительно SMS-авторизацию в кафе. Ваше ПО/настройки позволят одновременно работать как ХотСпот и в то же время авторизовываться по SMS?
 
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Контроллер Unifi, на Windows 7 (х86). Работает как ХотСпот, интеграция с 1С Отелем (паспортные данные) по ваучерам. Нужно сделать еще дополнительно SMS-авторизацию в кафе. Ваше ПО/настройки позволят одновременно работать как ХотСпот и в то же время авторизовываться по SMS?
Да. Создаете дополнительную сеть под смс с vlan.
 

Алексей IT

новичок
18 Июл 2018
1
0
3
42
Что имеем:
- Два входящих подключения интернета.
- Два mikrotik с несколькими vlan каждый, привязанных к bridge для разных целей.
Деревья VLAN с двух микротиков напрямую не пересекаются и доступ между ними только через инет (дабы не закольцевать провайдера).
- Сервер с Unifi Controller и двумя "сайтами" на котором "висит" несколько десятков "тарелок" тира AP с публичным доступом.
- Часть тарелок раздают инет 1 по vlan X без авторизации и пароля.
- Другая часть тарелок раздают инет 2 по vlan Y через hotspot с использованием ваучеров, но без пароля.
- Все тарелки по vlan Z раздают инет 3 запароленный доступ для внутренних нужд.
---
Нужно на инет 1 и 2 навесить идентификацию по SMS , притом чтоб hotspot с ваучерами на 2 инете по прежнему работал.
 
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Что имеем:
- Два входящих подключения интернета.
- Два mikrotik с несколькими vlan каждый, привязанных к bridge для разных целей.
Деревья VLAN с двух микротиков напрямую не пересекаются и доступ между ними только через инет (дабы не закольцевать провайдера).
- Сервер с Unifi Controller и двумя "сайтами" на котором "висит" несколько десятков "тарелок" тира AP с публичным доступом.
- Часть тарелок раздают инет 1 по vlan X без авторизации и пароля.
- Другая часть тарелок раздают инет 2 по vlan Y через hotspot с использованием ваучеров, но без пароля.
- Все тарелки по vlan Z раздают инет 3 запароленный доступ для внутренних нужд.
---
Нужно на инет 1 и 2 навесить идентификацию по SMS , притом чтоб hotspot с ваучерами на 2 инете по прежнему работал.
1) Ставите сервер (компьютер) физический или виртуальный например к микротику №1 (там должен быть Статический Белый IP адрес для подключения удаленных точек (хотспотов)). Инсталируете сами или с помощью нас наше решение (Тестовое ПО v237 (glibc >=2.19), имеются ограничения) по авторизации в сети wifi.
2) На микротике №1 создаете например VLAN50. Создаете отдельный Bridge50. Создаете новый dhcp сервер и прикрепляете его к созданному Bridge50. В этот Bridge50 помещаете созданный VLAN50.
3) На контроллере создаете открытую wifi сеть с VLAN50.
4) По инструкции (или мы) помещаете на микротик доп. файлы и настраиваете разделы hotspot & trafic flow.
5) Создаете VPN сервер на микротике №1 для подключений остальных удаленных микротиков. Можно обойтись и без VPN - пробросив конкретные порты.
6) Подключаем и настраиваем usb модем для отправки/приема смс или прикрепляем данные для отправки смс с любого агрегатора смс, который имеет api http.

Теперь на созданной открытой wifi сети с VLAN50 есть смс авторизация wifi.

7) На удаленных микротиках проделываем пункты 2, 3, 4 + подключаетесь по VPN или на прямую. Подсети должны быть разными. VLAN соответственно тоже.
 
Последнее редактирование:
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Последнее редактирование:
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Файлы для самостоятельной установки: (обновлены 01.01.2019)
Добавлены образы виртуальных машин.
 

Glazolin

участник
6 Фев 2019
4
1
5
36
Если у меня стоит весь комплект - USG, AP, switch, Cloud key, то правильно ли я понимаю, что данная схема подразумевает отказ от USG, замену его на микрот, а так же от части функционала контроллера, который требует наличия USG?
 
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Если у меня стоит весь комплект - USG, AP, switch, Cloud key, то правильно ли я понимаю, что данная схема подразумевает отказ от USG, замену его на микрот, а так же от части функционала контроллера, который требует наличия USG?
Нет. Ваше оборудование так и будет работать, как работало. Микротик выполняет роль хотспота. Можно до usg или после ставить микротик.
 
Последнее редактирование:

Glazolin

участник
6 Фев 2019
4
1
5
36
Решение работает, сервис smsc.ru подключается легко и быстро (как само подключение в конфигурации, так и регистрация и оплата аккаунта). Инструментарий управления базой вполне можно расширить самостоятельно, продавец отвечает на вопросы и подсказывает в какую сторону мыслить при настройке.
И всё бы было супер, если бы не одно "но", из-за которого пока, от этого решения вынужден отказатся - оказалось (к великому удивлению) что на микротике нельзя скрыть полностью пользователей друг от друга. Т.е. да, можно запретить трафик между клиентами, пинговаться они не будут, но любой сканер сети, который умеет в arp (а умеют почти все, например fing) будет видеть всех клиентов сети. Это оказалось неприемлимо для клиента (которому я собирал этот сервис).
На самом Unifi существует изоляция клиентов (галочка "Apply guest policies" для беспроводных и "Port isolation" для проводных), но всё это работает, когда оборудование Unifi напрямую видит друг друга, без посредника NAT в виде Микротика.

Но в целом, за исключением этого недостатка и небольшого недостатка в довольно скудной документации - это отличный сервис SMS аутентификации.
Кстати, я попробую через некоторое время написать альтернативный мануал по установке и настройке сервиса, который, с моей точки зрения был бы более понятен и охватывал кучу подводных камней с которыми я столкнулся из-за непонятных фраз или отсутствия описания.
 
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Спасибо за отзыв.
В микротиках можно изолировать друг от друга:
https://forum.mikrotik.com/viewtopic.php?t=2501
https://forummikrotik.ru/viewtopic.php?t=8332

Также если у вас "сканируют" вашу сеть, то применяем данное правило к нужному интерфейсу и забываем (в примере указан интерфейс ether1):
Код:
/ip firewall filter
add action=drop chain=input comment=Port_scanner_drop src-address-list=\
    "port scanners"
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=\
    tcp psd=21,3s,3,1
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=\
    tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=\
    tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=\
    tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=\
    tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=\
    tcp tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=\
    tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
На все порты:
https://wiki.mikrotik.com/wiki/Drop_port_scanners
 

Glazolin

участник
6 Фев 2019
4
1
5
36
В
Спасибо за отзыв.
В микротиках можно изолировать друг от друга:
https://forum.mikrotik.com/viewtopic.php?t=2501
https://forummikrotik.ru/viewtopic.php?t=8332

Также если у вас "сканируют" вашу сеть, то применяем данное правило к нужному интерфейсу и забываем (в примере указан интерфейс ether1):
...
На все порты:
https://wiki.mikrotik.com/wiki/Drop_port_scanners
В приведённых ссылках речь про изоляцию либо посредством VLAN (Что не подходит - не делать же влан на клиента - Тут и CCR нагибаться начнёт при 500 и более клиентах.), либо речь вообще об изоляции в вайфае самого Микрота (Кстати попробовали - ARP запросы ходят свободно при включённой этой изоляции.), что не интеренсно, так как мы тут про Unifi разговариваем.

Запрет сканирование же сети не даст возможности видеть от порта к порту на Микроте - да, это гуд, но точка Unifi, не подключенная впрямую (без NAT) в Unifi сеть (Т.е. когда она не в одном коллизионном домене с контроллером, USG и свитчом) - просто внутри себя пропускает arp запросы, не отправляя их на микрот, а значит этот запрет работать не будет для всех, кто сидит на одной точке доступа.
 

Glazolin

участник
6 Фев 2019
4
1
5
36
Ещё один вариант решения - взять роутер, перешить его на опенврт, сделать обычную авторизацию по WPA, закрыть фаерволом сеть снаружи, оставив dhcp, dns, http до внутренних сайтов и какой-нибудь vpn pptp, l2tp для особо нуждающихся. Пароль на точку - общий для всех, а вот vpn - уже поюзерно.
Вы темой не промахнулись? Здесь речь про SMS авторизацию на оборудовании Mikrotik и Ubiquti. Какие vpn поюзерно? Какое WPA? О чём вы вообще?
 
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
А не делаете ли вы аунтификацию черз фейсбук и гугл
Авторизация в сети Wi-Fi через социальные сети запрещена законом. Нет, не делаем. Google+ - закрывают проект. Facebook - есть встроенная в контроллере unifi.
 
Автор
dimacbz

dimacbz

WiFi-SMS.com
16 Июн 2014
1.436
227
75
wifi-sms.com
Виртуальный образ обновлен. Добавлены инструкции на Рабочий стол.