Wifi sms авторизация (идентификация) Spot4 в сетях wifi. Wifi Авторизация по звонку. | Ubiquiti форум UBNT: инструкции, настройка
4,80 звёзд 13 Votes
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v311.
Изменения:
Fix для KeeneticOS.

Добавлено:
В "История SMS" выбор месяца по статистике - по отправленным, принятым смс.
В "История SMS" => "Отправленные" - добавлено отображения профиля, с какого было отправлено авторизационное сообщение.

Обновление доступно для:
Debian 10 (Ubuntu 20, CentOS 8).

За тестовым ПО Spot4, по поводу тестирования сервиса или за обновлениями - обращайтесь по контактам в 1 пост
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Для работы с БД рекомендуется использовать Robo3T.

Для работы с БД используйте документацию с сайта разработчика: https://docs.mongodb.com/manual/tutorial/install-mongodb-on-debian/

Например, чтобы удалить (при тестировании) номер телефона или мак адрес устройства, в консоли пропишем:
Код:
mongo spot4
db.devices.remove({phone:"+79690001100"})

db.devices.remove({mac:"90:A3:73:F5:F6:35"})
 
Последнее редактирование:
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Стандартная тема с всплывающим адаптивным окном при нажатии на ссылку.
Данное всплывающее окно необходимо для информирования гостей о правилах предоставления сервиса, в том числе предупреждения гостей, если вы используете собранные данные в рекламных целях. При отсутствии предупреждения, с которым гость должен согласиться, гость может подать иск против лица, предоставляющего услуги WiFi, если докажет, что его данные были использованы без его согласия. Обычно штраф составляет 30т.р.
Если будет подобное предупреждение/правила использования сервиса, с которыми гость при подключении согласится, - никаких штрафов не будет и вы можете использовать свободно собранные данные в рекламных целях.

Так как вы собираете персональные данные, а идентификационные данные: номер телефона, MAC-адрес, обязательные к сбору и хранению в течение 12 месяцев, являются персональными данными, хоть и не содержат ФИО, вы должны выполнять требования Федерального закона от 27 июля 2006 г. N 152-ФЗ «О персональных данных». Согласно этому закону пользователь должен ознакомиться с тем, какие данные вы собираете и для чего, и дать согласие на этот сбор данных о нем. В данной теме имеется вся необходимая информация, с которой пользователь должен согласится. Если он не согласится - доступ в интернет он не получит соответственно.

Пример стандартной темы с всплывающим окном:
ССЫЛКА НА ТЕМУ


8414



Чтобы получить данную тему, обращайтесь по контактам:
Viber, Whatsapp, Telegram: +79626222731
e-mail: info@wifi-sms.com
 
Последнее редактирование:
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v316.

Добавлено:
Функция: "Избыточная отправка смс" в настройках хотспотов - позволяет отправлять сразу одну или несколько смс одному пользователю. Отправка смс идёт по кругу среди модемов или шлюзов, при доступности нескольких шлюзов в конфигурационном файле.

Обновление доступно для:
Debian 10 buster
Ubuntu 20 focal

За тестовым ПО Spot4, по поводу тестирования сервиса или за обновлениями - обращайтесь по контактам в 1 пост
 
Последнее редактирование:
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v317.

Изменения:
Обновление политики безопасности.

Добавлено:
Возвращена обратно возможность использования (тире, точки, нижнего подчеркивания) в названии хотспота.

Обновление доступно для:
Debian 10 buster
Ubuntu 20 focal

За тестовым ПО Spot4, по поводу тестирования сервиса или за обновлениями - обращайтесь по контактам в 1 пост
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v318.

Изменения:
Fix "Экспорт".

Обновление доступно для:
Debian 10 buster
Ubuntu 20 focal

За тестовым ПО Spot4, по поводу тестирования сервиса или за обновлениями - обращайтесь по контактам в 1 пост
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Создан Телеграм канал для оповещений выхода обновлений и изменений для Spot4, а также оповещений разного характера.
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Внимание для тех, кто получил тестовый дистрибутив или установил тестовую версию, но столкнулся с трудностями в реализации установки и настройки, а также для тех, кто приобрел ПО Spot4, но имеет НЕ стандартную схему сети и нужно установить ПО Spot4 в такую сеть. Либо просто нужно получить услугу удаленной установки и настройки ПО Spot4:
Мы НЕ подключаемся удалённо и НЕ оказываем услуги удаленной установки и настройки ПО Spot4 или иного БЕСПЛАТНО, только за отдельную плату, указанную в списке дополнительных услуг.
Настраивайте самостоятельно, следуя инструкции или воспользуйтесь нашими дополнительными услугами.

Вы можете установить/настроить самостоятельно, следуя инструкциям. Или заказать установку/настройку.


8861






Перед запросом для настройки сети - подготовьте схему сети и необходимые доступы.

#####################################################################
Перед настройкой хотспота / или при выключенном хотспот сервере
нужно чтоб в гостевой сети у пользователя был интернет
чтоб открывался адрес на http://server: port/
#####################################################################
 
Последнее редактирование:

tgrba

новичок
7 Сен 2019
1
0
3
34
Здравствуйте, а есть мануал по созданию своей темы?
интересует в частности обязательные тэги, поля и т.д. в разметке
Собственно необходимо сделать полный кастом в стиле компании, если с полем ввода телефона понятно,
то никак не могу разобраться от куда подгружается поле ввода кода смс.
По идее должно от сюда /static/uam-forms/check-sms.html?
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Здравствуйте, а есть мануал по созданию своей темы?
интересует в частности обязательные тэги, поля и т.д. в разметке
Собственно необходимо сделать полный кастом в стиле компании, если с полем ввода телефона понятно,
то никак не могу разобраться от куда подгружается поле ввода кода смс.
По идее должно от сюда /static/uam-forms/check-sms.html?
Здравствуйте.
Техническая поддержка клиентам осуществляется при обращении на электронную почту или любой мессенджер с предоставлением ключа активации.
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v328 для Debian 10.
Fix [callee], REindex netflow.
Добавлена статистика по количеству авторизаций по звонку к смс статистике.
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Внимание. Изменяется порядок и стоимость удаленного техобслуживания, консультирования, иных услуг для ПО Spot4.
Подробней о порядке, сроках и стоимости обслуживания, а также о "Техпакетах" в Телеграм канале.
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v339 (бета версия) для Debian 10,
Открытие авторизационного окна на устройствах Apple в полноценном браузере после нажатия на кнопку во временном окне.

Обновление касается только для роутеров Mikrotik и работает только с ними.

Откройте конфигурационный файл config.json и после строчки "HTTP_PORT": 8080,
добавьте:
"APPLE_PORT": 8082,

По умолчанию используется порт 8082 tcp (можно изменять в config.json).
Нужно добавить правила в микротик после обновления на версию 339:
/ip dns static
add address=10.10.10.10 name=captive.apple.com
add address=10.10.10.10 name=netcts.cdn-apple.com

/ip firewall nat
add action=dst-nat chain=hs-unauth dst-address=10.10.10.10 dst-port=80 \
protocol=tcp to-addresses=10.10.10.10 to-ports=8082 place-before=0
add action=dst-nat chain=hs-auth dst-address=10.10.10.10 dst-port=80 protocol=\
tcp to-addresses=10.10.10.10 to-ports=8080 place-before=0

Где 10.10.10.10 - это адрес вашего сервера, 8082 в config.json APPLE_PORT, 8080 - в config.json порт авторизации.

В Walled Garden должно быть пусто, а в Walled Garden IP List стандартное правило на ваш сервер.
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Объявляем тестирование для тех, кому интересно программное обеспечение (далее - программа) в сети WiFi с оплатой по банковской карте при подключении.
Количество мест для тестирования ограниченно.
Программа в стадии альфа теста. Программа функционирует, отсутствует административная часть для управления и статистики (в работе).
Для тестирования обязательно иметь микротик и аккаунт на ЮMoney https://yoomoney.ru/ (бывший Яндекс.Деньги - сейчас сервис Сбербанка). Если вы ранее имели аккаунт на Яндекс.Деньги - то просто залогиньтесь на ЮMoney. Предварительный старт тестирования 10 июля.
Есть возможность приобрести программу со скидкой 50%, пока проходит тестирование и разработка. Количество по скидке ограниченно и составляет 10 шт., приоритет приобрести со скидкой у тех, кто проводит тестирование.
Программа будет двух видов: однопрофильная и многопрофильная, для установки на вашем сервере. Стоимость программ соответственно разная.
Однопрофильная: можно выставить только одну стоимость, только один личный кабинет, только один профиль для оформления.
Многопрофильная: можно выставить разную стоимость по выбору, не ограниченное кол-во личных кабинетов, не ограниченное кол-во профилей для оформления.
Интересующие вопросы задавайте в Telegram: +79626222731

Для регистрации в ЮMoney и приема платежей - достаточно просто зарегистрироваться в сервисе и можно сразу принимать платежи!

Предварительное время окончания работ и начало продаж программы: август 2021г.

8969
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v356 для Debian 10 buster и Debian 11 bullseye.

Исправления:
внесены изменения и исправления во внутренний код
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Вышло обновление v361 для Debian 9, 10, 11.

Исправления:
внесены изменения и исправления во внутренний код
 
Автор
dimacbz

dimacbz

Moderator
16 Июн 2014
1.474
237
75
Здравствуйте.
Google 24 сентября 2021 года выпустила исправление уязвимости CVE-2021-37973, затронув напрямую работу хотспота, вызывая сбой Android WebView на оборудовании, которое работает на операционной системе Android. Причем Google пока не раскрывает своё решение и из-за этого некоторые разработчики приложений самостоятельно ищут пути решения, а пользователи не могут авторизоваться.
Из-за этого некоторые пользователи могли видеть ошибку при коннекте к порталу или после прохождения идентификации "You are not logged in" - с не возможностью дальнейшего использования интернет соединения.
Пользователей с техникой Apple не затронула эта проблема.

Мы работаем над решением данной проблемы и выпустили обновление. В обновлении авторизация работает как и прежде у пользователей, но после прохождения появится: "Error 404: Not Found" - закройте и продолжите пользоваться, авторизация пройдена - не обращайте на это внимание - в следующем обновлении исправим.

Обновление v366 (beta) для Ubuntu 20 / Debian 9, 10, 11.
 
Последнее редактирование: